Tuesday, October 01, 2024
Sunday, July 17, 2016
Tuesday, December 04, 2012
The 2012 PopCult Gift Guide Day Three: Television Series
Betraying my age here, when I was growing up, the idea of owning a collection of TV shows was incomprehensible. There was no way for a consumer to purchase movies or TV shows because home video hadn't been invented yet. Even in the days of VHS, the limitations of the format pushed the practicality of selling an entire long-running television series just out of reach.
DVD and Blu Ray has changed that. Now, if you're a die-hard fan of a television series, you can buy each season as they become available, or wait until the series has ended and buy a boxed set of the entire run. Today's gift idea is five suggested boxed sets of complete runs of TV shows. The links will take you to Amazon (this blog, unlike others, does NOT get a cut of any purchase you make), but you may find better prices at other retailers such as Best Buy, Sam's club or Costco.
Smallville
This retelling of the pre-Metropolis days of Clark Kent, before he became Superman, wrapped up ten seasons on the air in 2011, and was highly regarded as one of the best live-action depictions of The Man of Steel. With Tom Welling as Clark, and a cast that included Annette O'Toole, John Schneider, Michael Rosenbaum,Allison Mack, Kristin Kreuk, with guest appearances by Christopher Reeve, Margot Kidder and Michael McKean, Smallville turned out to be a first-class television series that brought a lot of DC Comics characters to a mainstream audience for the first time. You can relive those ten seasons with Smallville The Complete Series.
DVD and Blu Ray has changed that. Now, if you're a die-hard fan of a television series, you can buy each season as they become available, or wait until the series has ended and buy a boxed set of the entire run. Today's gift idea is five suggested boxed sets of complete runs of TV shows. The links will take you to Amazon (this blog, unlike others, does NOT get a cut of any purchase you make), but you may find better prices at other retailers such as Best Buy, Sam's club or Costco.
Smallville
This retelling of the pre-Metropolis days of Clark Kent, before he became Superman, wrapped up ten seasons on the air in 2011, and was highly regarded as one of the best live-action depictions of The Man of Steel. With Tom Welling as Clark, and a cast that included Annette O'Toole, John Schneider, Michael Rosenbaum,Allison Mack, Kristin Kreuk, with guest appearances by Christopher Reeve, Margot Kidder and Michael McKean, Smallville turned out to be a first-class television series that brought a lot of DC Comics characters to a mainstream audience for the first time. You can relive those ten seasons with Smallville The Complete Series.Monday, December 03, 2012
The 2012 PopCult Gift Guide Day Two: Bond...James Bond
This year marks the fiftieth anniversary of the quintessential spy, James Bond, on film. Theater-goers have reacted very favorably to the latest entry in the long-running franchise, "Skyfall," and new or lapsed fans can catch up instantly with the "Bond 50" box set, which collects every "official" entry in the James Bond film canon.Starting with 1962's "Dr. No" and fizzling out with 2010's "Quantum of Solace," this set brings you all the highs and lows of the Bond franchise. "Never Say Never Again" is missing because, like the first "Casino Royale," it's not one of the EON Productions Bond movies.
Now, oddly enough, the Blu Ray version of this set, which contains an extra disc, is availalbe for much less than the DVD version. At least that's the way it is at Amazon, where the DVD version is nearly three hndred dollars, while the Blu Ray is a little more than half that. The bonus Blu Ray is an hour-long overview of the Bond Franchise.
If you don't want to dump that much money supporting a British secret agent's martini habit, you can actually go back to the source material with Ian Fleming's original James Bond novels, which can be found in nifty new editions for around fifteen bucks a pop. If your ordered them now from a local bookseller like Taylor's, you should have them in plenty of time for gifting.And if you really want to go on the cheap, at most area Big Lots stores, you can find really good DVD editions of most of the James Bond movies for five bucks a pop. At that price, we're talking stocking stuffers.
The RFC 2012 Sampler Looks Back At A Great Year For Local Music
[HTML1]
Radio Free Charleston 175, "Dunbar Lanes Shirt," is a sampler of just a tiny amount of the great local music that we brought you in 2012. We'll revisit songs from Red Audio, In The Company of Wolves, Godmode Broadway, and The Charleston Light Opera Guild production of "The Color Purple."
Our title shirt this week comes to us from the newly reopened Dunbar Lanes, the area's coziest little bowling alley, tucked away in the heart of the hub of the Kanawha Valley, Dunbar. After the previous owners retired and left for Florida and the bowling alley lay dormant for a few months, the Dunbar landmark reopened last Friday and the new management promises to turn it into the hippest bowling alley in the state.
Host segments were shot at Joplin Park in South Charleston early Sunday morning before the gloomy clouds and rain blew through.
Radio Free Charleston 175, "Dunbar Lanes Shirt," is a sampler of just a tiny amount of the great local music that we brought you in 2012. We'll revisit songs from Red Audio, In The Company of Wolves, Godmode Broadway, and The Charleston Light Opera Guild production of "The Color Purple."
Our title shirt this week comes to us from the newly reopened Dunbar Lanes, the area's coziest little bowling alley, tucked away in the heart of the hub of the Kanawha Valley, Dunbar. After the previous owners retired and left for Florida and the bowling alley lay dormant for a few months, the Dunbar landmark reopened last Friday and the new management promises to turn it into the hippest bowling alley in the state.Host segments were shot at Joplin Park in South Charleston early Sunday morning before the gloomy clouds and rain blew through.
Sunday, December 02, 2012
The 2012 PopCult Gift Guide Day One: The Beatles
We're kicking off our 8th Annual PopCult Gift Guide today and we're doing it with The Beatles. This year, there's one huge gift that the die-hard Beatle fan will definitely want. It's The Beatles complete box set of studio recordings on vinyl.This is the vinyl debut of the digitally remastered versions of The Beatles albums which were released on CD and on iTunes just a couple of years ago. Even if you have the original vinyl, you should be able to detect subtle differences in these new pressings. All the albums are restored to their original packaging, which includes the inserts with the "Sgt. Pepper" album, the posters and photos with "The White Album," and the twenty-four page storybook that came with "Magical Mystery Tour."
Monday Morning Art: Balls
Today's art is a digital painting over a digitally-assaulted photograph of one of the bowling ball racks at the newly-reopened Dunbar Lanes. It doesn't look like that in real life. Click to enlarge.Dunbar Lanes reopened under new management last Friday, and they also supplied the title shirt for RFC 175, "Dunbar Lanes Shirt," which will hit PopCult later tonight. Also later, The 2012 PopCult Gift Guide kicks off. So just keep hitting "refresh," okay?
Sunday Evening Video: The Hitchhiker's Guide To The Daleks
[HTML1]
This came up in a conversation this weekend...
This came up in a conversation this weekend...
Thursday, November 29, 2012
750 Words About Dick
The PopCulteer
November 30, 2012
This week we're devoting the PopCulteer to a review of a digital download. In April of this year, over four nights at the Orpheum Theater in Los Angeles, Eric Idle staged his original play, "What About Dick?" with an all star cast of Brit expatriates performing a fairly undescribable but hilarious evening of conceptual comic theatre.
Rather than go for television or theatrical release, "What About Dick?" is a digital download that combines the best of those four performances. The plot is indecipherable. The best I can come up with to explain it is that "What About Dick?" combines elements of Monty Python with the stream of consciousness storytelling of The Firesign Theater into an hysterical hybrid where even the cast members have a hard time keeping a straight face.
November 30, 2012
This week we're devoting the PopCulteer to a review of a digital download. In April of this year, over four nights at the Orpheum Theater in Los Angeles, Eric Idle staged his original play, "What About Dick?" with an all star cast of Brit expatriates performing a fairly undescribable but hilarious evening of conceptual comic theatre.
Rather than go for television or theatrical release, "What About Dick?" is a digital download that combines the best of those four performances. The plot is indecipherable. The best I can come up with to explain it is that "What About Dick?" combines elements of Monty Python with the stream of consciousness storytelling of The Firesign Theater into an hysterical hybrid where even the cast members have a hard time keeping a straight face.
Don't Forget "Mary"
[HTML1]
Up above you see a special video of the Trio that ends the first act of "Mary A Rock Opera." You still have four more chances to see this Dan kehde-Mark Scarpelli homegrown Christmas classic, tonight through Staruday at 8 PM, and Saturday afternoon at 2 PM at the WVSU Capitol Center Theater.
The story of the nine months prior to the birth of Jesus Christ through the eyes of a young girl destined to be the most important woman in the Christian tradition, MARY has become a family friendly holiday tradition throughout the greater Charleston area, and continues to give audiences new insight to the days and months leading up to the first Christmas. New to this Contemporary Youth Arts Company production this year is the introduction of a second cast of young performers who will take on the principle roles during the matinee.
The above video is a performance of the stirring "Trio" that ends the first act, with both sets of actresses portraying Elizabeth, The Archangel Gabriel and Mary combining to form a "Double Trio" of six wonderful voices. As Elizabeth we have Lo Mallory and Susanna Tucker. Singing the role of Gabriel are Maddy Gourevitch and Susanna Morris. In the tile role of Mary are Katie Shaver and Rowan Maher.
The piano is played by composer, Mark Scarpelli. Speical thanks to Lee Harrah for the camera assist.
The WVSU Capitol Center Theater is located at 123 Summers Street, Charleston. Tickets are available at the door prior to each performance: $10.00 for adults. $6.00 for students and seniors (65+). Call the WVSU Capitol Center Theater office at 342-6522 for advance ticket sales and group rates.
Up above you see a special video of the Trio that ends the first act of "Mary A Rock Opera." You still have four more chances to see this Dan kehde-Mark Scarpelli homegrown Christmas classic, tonight through Staruday at 8 PM, and Saturday afternoon at 2 PM at the WVSU Capitol Center Theater.
The story of the nine months prior to the birth of Jesus Christ through the eyes of a young girl destined to be the most important woman in the Christian tradition, MARY has become a family friendly holiday tradition throughout the greater Charleston area, and continues to give audiences new insight to the days and months leading up to the first Christmas. New to this Contemporary Youth Arts Company production this year is the introduction of a second cast of young performers who will take on the principle roles during the matinee.
The above video is a performance of the stirring "Trio" that ends the first act, with both sets of actresses portraying Elizabeth, The Archangel Gabriel and Mary combining to form a "Double Trio" of six wonderful voices. As Elizabeth we have Lo Mallory and Susanna Tucker. Singing the role of Gabriel are Maddy Gourevitch and Susanna Morris. In the tile role of Mary are Katie Shaver and Rowan Maher.
The piano is played by composer, Mark Scarpelli. Speical thanks to Lee Harrah for the camera assist.
The WVSU Capitol Center Theater is located at 123 Summers Street, Charleston. Tickets are available at the door prior to each performance: $10.00 for adults. $6.00 for students and seniors (65+). Call the WVSU Capitol Center Theater office at 342-6522 for advance ticket sales and group rates.
Sunday, November 25, 2012
Monday Morning Art: Stark Charleston Revisited
Thursday, November 22, 2012
The Cheesy Knockoffs Return
The PopCulteer November 23, 2012
So it's Black Friday, the day after Thanksgiving, a day where hardly anybody's going to bother going on the Internet to read anything. Yet, the PopCulteer always comes on Friday and with the bonus of knowing that not too many people are going to bother reading this, I'm going to take this week for a self-indulgent visit to my own past as a nationally published columnist.
Back in the late 1990's, I was the action figure columnist for Toy Trader Magazine. Toy Trader was a competitor to Krause Publications' Toy Shop and thanks to having several pages of high quality articles each month, we were rapidly eating away at Toy Shop's readership. This came to a sudden end when Toy Trader's parent company was aquired by Toy Shop's parent company and our magazine was assimilated into theirs. Since Krause only paid one-tenth as much as we were getting from Toy Trader Magazine, none of the writers made the leap to the new publication. I continued covering action figures for MasterCollector.com for a few years, but then moved on to this here PopCult blog of which you should already be aware.
Monday, November 19, 2012
Qiet, "Mary," Farnsworth, DEVO Hats and breakfast cereal on RFC 174
[HTML1]
Up top you see RFC 174 "Mark Wolfe Design Shirt." This week's episode of Radio Free Charleston features music from Qiet and Farnsworth, plus a special performance from the Dan Khede/Mark Scarpelli rock opera, MARY. We also have some fresh DEVO hat animation and part of a complete breakfast. Host segments were shot on the river side of our beautiful State Capitol Building. Our titular shirt comes to us from our good friend, Mark Wolfe, and plugs Mark Wolfe Design, pretty much the hippest design firm in town.
We start the show with something childish and hysterical and we're not going to say anything more about it.
Up top you see RFC 174 "Mark Wolfe Design Shirt." This week's episode of Radio Free Charleston features music from Qiet and Farnsworth, plus a special performance from the Dan Khede/Mark Scarpelli rock opera, MARY. We also have some fresh DEVO hat animation and part of a complete breakfast. Host segments were shot on the river side of our beautiful State Capitol Building. Our titular shirt comes to us from our good friend, Mark Wolfe, and plugs Mark Wolfe Design, pretty much the hippest design firm in town.We start the show with something childish and hysterical and we're not going to say anything more about it.
Sunday, November 18, 2012
Monday Morning Art: Ragnarok
The theme for last night's edition of Dr. Sketchy's Anti-Art School was Ragnaok, which is the term for the end of the world in Norse mythology. It was chosen as the theme because of the predictions of the end of the world thanks to the Mayan Calendar ending.Because the Mayans and The Norse are just like two peas in a pod, or something. But it was a fun night, and prizes included John Hodgmen's new book, the "Cards Against Humanity" game and, yes, Twinkies.
Anyway, today we have some quick digital paintings of Vorel Sarkany as C'Thulu(above), Penny Maple as The whore of Babylon and Molly Tilly and Cornelius Dapperdu as John Hodgeman and Jonathan Coulton. As always, click to enlarge. And remember, tonight in PopCult, it's time for a new episode of Radio Free Charleston.

Friday, November 16, 2012
The End Of The World, Zombie Baby Boom and The Wayward Girls
The PopCulteer November 16, 2012
We've got just a few short items for this week's PopCulteer and then we're going to wrap it up with a photo essay featuring the Wayward Girls School of Burlesque. It's a little weird not having an ArtWalk on the third Thursday of the month, but in November they always have it on Black Friday. Your PopCulteer is still trying to figure out a way to photograph the exhibits next week without setting foot in a retail establishment on Black Friday. Stay tuned to see how that works out.
Sunday, November 11, 2012
Monday Morning Art: Hello Kitty

This week we kick off PopCult with a digital painting of our own Kitty Killton misusing a couch, based on a photo taken last week at a shoot for The Wayward Girls School of Burlesque. You will be seeing way more images from this photo shoot in the coming weeks. As always, click on it to see a bigger version.
Sunday Evening Video: Veteran's Day
[HTML1]
In honor of Veteran's Day, we re-present the three-part Radio Free Charleston special from the "Tribute To The Troops II" concert, held last August at the Amphitheater in St. Albans City Park. Thanking veterans and active duty military for their service to our Democracy.
In honor of Veteran's Day, we re-present the three-part Radio Free Charleston special from the "Tribute To The Troops II" concert, held last August at the Amphitheater in St. Albans City Park. Thanking veterans and active duty military for their service to our Democracy.
Thursday, November 08, 2012
The Great Rock And Roll Swindle 2012
The PopCulteer November 7, 2012
It's finally over. Months, and in some cases years of campaigning for control of the White House, came to an end Tuesday as voters, even despite successful attempts at voter suppression by Republican governors and legislators, chose to give Barack Obama four more years to dig us out of the hole that the previous administration had placed us in.
There has been a small amount of gloating and taunting, some of it richly deserved. And on the losing side, a laughable amount of despair and hysterical panic and doomsaying, but at least it's over. Now we can study the aftermath and assess the damage.
Monday, November 05, 2012
Punk Cabaret, Cool Jazz and Hot Rock on RFC 173
[HTML1]
Above you should see RFC 173 "Calvin The Spiffy Spaceman Shirt" This episode of Radio Free Charleston features music from Frenchy and the Punk, Amanda Brigette and The Nanker Phelge, plus a hilarious outtake from Felix Baumgardner's Space Dive and a look at the newest Olympic sport, Spumling.
[caption id="attachment_9589" align="aligncenter" width="500"]
Frenchy and the Punk[/caption]
Above you should see RFC 173 "Calvin The Spiffy Spaceman Shirt" This episode of Radio Free Charleston features music from Frenchy and the Punk, Amanda Brigette and The Nanker Phelge, plus a hilarious outtake from Felix Baumgardner's Space Dive and a look at the newest Olympic sport, Spumling.
[caption id="attachment_9589" align="aligncenter" width="500"]
Frenchy and the Punk[/caption]Frenchy and Punk are featured on the show in advance of their November 7, 2012 gig at The Empty Glass in Charleston, WV, where they will be appearing with Qiet. While the goth/cabaret duo are promoting their new CD, "Hey, Hey, Cabaret," we have them on the show this week with the song "The Magician and The Dancer" from their 2010 CD, "Happy Madness."
Sunday, November 04, 2012
Monday Morning Art: The Wayward Girls
Over the weekend I was lucky enough to be invited to be one of the photographers for The Wayward Girls School of Burlesque. It was a fun evening, and I got a lot of great pictures of the ladies, but production of RFC 173 (coming tonight to PopCult) kept me from processing and editing the photos, so this week our art is just the first taste from the session, a digital painting of Elle Xombeah, Susie Sketchmann and Pepper Fandango are in the back row, with Lilli Lugosi, Penny Maple and Kitty Killlton in front. Stay tuned to PopCult for news of the Wayward Girls' next performance, and for more photos. Click to enlarge.
Sunday Evening Video: Frenchy and the Punk
[HTML1]
Our buddies from New York, Frenchy and the Punk, will be coming to The Empty Glass Wednesday to perform songs from their brand-new CD. Also on the bill is Huntington's Qiet, so it should make for a wild night of original music, and the RFC crew will be on hand. Our video tonight is RFC 143, which focused on Frenchy and the Punk during a summer, 2011 visit. Wednesday night could well be the show of the year, and you can get a taste of Frenchy and the Punk here.
You will get an andditonal taste of the band this week on Radio Free Charleston 173, where we will bring you an unseen performance from Frenchy and the Punk's last visit to The Empty Glass, along with new music from The Nanker Phelge and Amand Bridgette, plus a ilarious outtake from Felix Baumgartner's Space Dive. Look for RFC 173, "Calvin The Spiffy Spaceman Shirt," Monday night in PopCult.
Our buddies from New York, Frenchy and the Punk, will be coming to The Empty Glass Wednesday to perform songs from their brand-new CD. Also on the bill is Huntington's Qiet, so it should make for a wild night of original music, and the RFC crew will be on hand. Our video tonight is RFC 143, which focused on Frenchy and the Punk during a summer, 2011 visit. Wednesday night could well be the show of the year, and you can get a taste of Frenchy and the Punk here.You will get an andditonal taste of the band this week on Radio Free Charleston 173, where we will bring you an unseen performance from Frenchy and the Punk's last visit to The Empty Glass, along with new music from The Nanker Phelge and Amand Bridgette, plus a ilarious outtake from Felix Baumgartner's Space Dive. Look for RFC 173, "Calvin The Spiffy Spaceman Shirt," Monday night in PopCult.
Thursday, November 01, 2012
November Randomosity
The PopCulteer November 2, 2012
This week, your PopCulteer is all over the map. We're just gonna present short, random items about a variety of topics of which we are not certain as we write this introductory sentence. Part of it is because the weather has sort of scrambled our brains and upset our routines. Part of it is because there's just so darn much stuff to talk about this week. Most of it is because we put off writing this column until the last minute and had no idea what we're going to do.
Sunday, October 28, 2012
Monday Morning Art: Halloween Thrills
In today's art, we are going back to last week's edition of Dr. Sketchy's, which focused on Vampirella. This week I've digitally assaulted seven photos to approximate the look of the black-and-white artwork that was featured back in Warren Publishing's Vampirella magazine when I was growing up. You will see Penny Maple as Vampirella, Elle Xombeah as Adam Van Helsing and Lilli Lugosi as Lilith.Click the images to see them larger. Be warned that some of the images after the jump may not be safe for work. We will likely have more images from this edition of Dr. Sketchy's next week.
Sunday Evening Video: 2012 HallowEast Zombie Walk
[HTML1]
The clip you see at the top of this post is our PopCult Instant Video of the 2012 HallowEast Zombie Walk, which took place less than 24 hours before this was posted. This year's Zombie Walk started at Moxxee, the East End's ultra-hip coffee shop, and meandered down Lee, Bradford, and Quarrier Streets before ending at the HallowEast Costume Crawl on the corner of Elizabeth and Washington Street. As always, it was tremendous fun seeing all the ghouls and zombies and zombie hunters come out for the annual shamble. One nice addition this year was that the route took our undead friends through a residential section and the residents played along just fine.
In this clip, you will see the Cemetery Knights hearses, Carl from "The Walking Dead," a zombie chain gang, a zombie alien on a leash, a few zombie hunters, and a few wholesome zombie families. And that's just the tip of the iceberg. If you watch closely, you may even see East End Main Street's Ric Cavender and HallowEast's proud papa, Mark Wolfe, sprinkled among the rotting crowd.
Our music is part of a contest this year. The first person in the comments section who can identify the source of our music will get a free Basil Wolverton "Space Hawk" comic book, worth an estimated fifteen cents. Since YouTube now lets us get away with murder in terms of running times, in the next day or two we will probably post all our unedited raw footage, with no background music, so you can enjoy the unedited Zombie Walk experience and overhear all the inappropriate conversations that our cameras accidentally picked up.
The clip you see at the top of this post is our PopCult Instant Video of the 2012 HallowEast Zombie Walk, which took place less than 24 hours before this was posted. This year's Zombie Walk started at Moxxee, the East End's ultra-hip coffee shop, and meandered down Lee, Bradford, and Quarrier Streets before ending at the HallowEast Costume Crawl on the corner of Elizabeth and Washington Street. As always, it was tremendous fun seeing all the ghouls and zombies and zombie hunters come out for the annual shamble. One nice addition this year was that the route took our undead friends through a residential section and the residents played along just fine.In this clip, you will see the Cemetery Knights hearses, Carl from "The Walking Dead," a zombie chain gang, a zombie alien on a leash, a few zombie hunters, and a few wholesome zombie families. And that's just the tip of the iceberg. If you watch closely, you may even see East End Main Street's Ric Cavender and HallowEast's proud papa, Mark Wolfe, sprinkled among the rotting crowd.
Our music is part of a contest this year. The first person in the comments section who can identify the source of our music will get a free Basil Wolverton "Space Hawk" comic book, worth an estimated fifteen cents. Since YouTube now lets us get away with murder in terms of running times, in the next day or two we will probably post all our unedited raw footage, with no background music, so you can enjoy the unedited Zombie Walk experience and overhear all the inappropriate conversations that our cameras accidentally picked up.
Thursday, October 25, 2012
HallowEast IV and ArtMares
The PopCulteer October 26, 2012
It's the weekend before Halloween and there's just way the hell too much stuff to do in and around Charleston. Your Popculteer will be at the ArtMares reception tonight at Contemporary Galleries from 6 to 10 PM, where there will be beer, wine, and horsd'oeuvres, plus live music from Sean Sydnor. In addition to my work, nearly thirty other local artists (like Olivia Burch and Rebecca Recco, seen right) will be showing off their dark side with macabre, horror-themed works. The bulk of this week's column is a photo essay devoted to the ArtMares exhibit.
But that's not all that's going on. It's the fourth year for HallowEast and this year, they have combined with Festivall Fall to make sure that there are more really cool things going on at the same time than any one person could humanly attend. Tonight, while the ArtMares reception is going on, there will be a special Live On The Levee encore featuring Radio Free Charleston guests The Tom McGees and Qiet, plus two of Columbus' ships. At 10 PM, the No Pants Players bring their filthy, dirty adult comedy to Timothy's, downstairs at the Quarrier Diner.
Monday, October 22, 2012
Halloween 2012 on RFC
[HTML1]
At the head of this post, you see our brand new Halloween treat, Radio Free Charleston 172, "Nightmare In Wax shirt." The bulk of this special episode was recorded on September 29 at the first Shocka-Con horror/science fiction convention. Our musical guests are The Tom McGees, The Nanker Phelge, and The Renfields. Plus, we have a short film by convention guest, Appalachian horror author Frank Larnerd.
Shocka-Con is the brainchild of Mike and Rose Winland, of Mike Winland Studios fame, and it was a spectacular success, drawing over 2500 people. It was an all day convention, with vendors and special guests set up in tents around the Indian Mound in South Charleston while seminars were held at the South Charleston Public Library and movies were screened at the LaBelle Theater. The evening ended with a Monster Parade up D Street and a free concert at the Mound Stage.
At the head of this post, you see our brand new Halloween treat, Radio Free Charleston 172, "Nightmare In Wax shirt." The bulk of this special episode was recorded on September 29 at the first Shocka-Con horror/science fiction convention. Our musical guests are The Tom McGees, The Nanker Phelge, and The Renfields. Plus, we have a short film by convention guest, Appalachian horror author Frank Larnerd.Shocka-Con is the brainchild of Mike and Rose Winland, of Mike Winland Studios fame, and it was a spectacular success, drawing over 2500 people. It was an all day convention, with vendors and special guests set up in tents around the Indian Mound in South Charleston while seminars were held at the South Charleston Public Library and movies were screened at the LaBelle Theater. The evening ended with a Monster Parade up D Street and a free concert at the Mound Stage.
Sunday, October 21, 2012
Monday Morning Art: Vamping It Up For Halloween
Last night saw the Halloween edition of Dr. Sketchy's Anti-Art School for October, and it was a cool night of Halloweenish posing as the theme was Vampirella and the location was part of Kanawha Player's Haunted House, the Beauregard Nightmare Factory. Our models are Penny Maple and Elle Xombeah, above, and Lilli Lugosi, below. These are quick digital paintings over photographs. More detailed efforts from last night's session will be seen here next week. Click to see the images larger.Check PopCult later tonight for full production notes and Radio Free Charleston 172, "Nightmare In Wax Shirt," our 2012 Hlloween special, recorded mostly at Shocka Con, featuring music from The Tom mcGees, The nanker Phelge and The Renfields.
Friday, October 19, 2012
The Harpejji Cometh During ArtWalk
The PopCulteer October 19, 2012
It's ArtWalk time, and...we didn't do so good. Your PopCulteer managed to leave the house twice yesterday without his still camera. After I drove off the first time without it, I returned and was interrupted by one of those damnable political robo-calls (Really? West Virginians For Life wants me to vote for John Rases? They couldn't find a more wrong tree up which to bark.) and left the house a second time without my trusty Canon.
I was armed with my Kodak Zi8, which I use for video. I'm not as happy with the still photos it takes, but it was too late to make another trip back home.
The reason I had the Zi8 was that I'd planned to shoot my ArtWalk photos quickly so that I could record the public debut of the Harpejji, an exotic intrument with 24 strings of wonder, which now resides in the hands of Maestro, Chuck Biel (seen above, right).
So we start off this week's PopCulteer with a PopCult Instant Video of Chuck and his Harpejji, sitting in with another virtuoso, Sean Sydnor, recorded just last night at Capitol Roasters, in an ambient piece of wonder, with just a touch of animation by Frank Panucci. Then we'll look at four stops on last night's ArtWalk.
[HTML1]
Thursday, October 18, 2012
Hackers Unite In Charleston

Hackercon 3 (Doomsday Eve) starts Friday. This edition of the annual information and cyber-security symposium will explore Doomsday and survival scenarios in the age of the internet.In addition to workshops and contests, there will be presentation on Doomsday tactics, speakers including Larry Pesce and K.C. Yerrid, and a presentation of the film, "Reboot."
Hackercon 3 runs Friday through Sunday at the Ramada on Kanawha Boulevard (formerly The Charleston House Holiday Inn). Some of the workshops will take place down the boulevard at Digiso. Events kick off at 8 AM Friday, and you can find a full schedule here.
Monday, October 15, 2012
The Best of Halloween On RFC 171
[HTML1]
[caption id="attachment_9396" align="alignright" width="250"]
Back in the Gazz.com days.[/caption]
Radio Free Charleston's 171st episode, "Skull Shirt," is online now and it's a doozy. This on- hour-five-minute compilation show brings you highlights from the first five years worth of Radio Free Charleston Halloween specials. Most of these shows were multi-part or bonus length epics and each year's special was different in its own twisted little way.
[caption id="attachment_9396" align="alignright" width="250"]
Back in the Gazz.com days.[/caption]Radio Free Charleston's 171st episode, "Skull Shirt," is online now and it's a doozy. This on- hour-five-minute compilation show brings you highlights from the first five years worth of Radio Free Charleston Halloween specials. Most of these shows were multi-part or bonus length epics and each year's special was different in its own twisted little way.
Sunday, October 14, 2012
Monday Morning Art: ArtMares Preview
ArtMares, the horror-themed art show, will once again be part of HallowEast this year, and I am proud to once again be incuded among the artists whose work will be on display. What you see above is a pencil study for the digital painting that became "Ghouls Night Out," my new entry for this year's exhibit. You may rememer this image from last year. You'll have to wait to see which of the two fully-painted versions I posted as Monday Morning Art last year made it into ArtMares.This image is based on a photo taken at the Halloween edition of Dr. Sketchy's Anti-Art School last year. It features Lavendar Menace, Elle Xombeah, Vorel Sarkany and Penny Maple. This year's Halloween Dr. Sketchy's session happens Sunday, October 21 at Kanawha Players Theater, and the theme is Vampirella!
ArtMares opens at Contemporary Galleries on October 24 for a sneak preview. On Friday, October 26, an artist's reception will be held at Contemporary Galleries with music from the incredible Sean Sydnor. For more details, check the HallowEast IV website.
Sunday Evening Video: Time And Distance
Friday, October 12, 2012
Burgers, Big Daddy and Captain Action
The PopCulteer October 12, 2012
It's a mixed bag of coolness this week, so let's dive in, shall we?
Rockin' Robin's First Anniversary
One year ago, Rockin Robin's Burgers and Shakes opened in Clendenin, and they've been a catering presence supporting the local music scene ever since. Saturday they're putting on all-day outdoor show with music and contests, and with a beautiful Fall day predicted by the Mational Weather Service, it should be one of the highlights of a very cool weekend.
A Hot Dog Eating Contest kicks things off at Noon, while a Costume Contest will be judged at 5 PM. At 3 PM there will be a Pumpkin carving Contest.
Sunday, October 07, 2012
Monday Morning Art: Onward Wayward Girls.
The Wayward Girls School of Burlesque made their debut September 29 at The Empty Glass, dancing to music from Pepper Fandango. We'll have news on their next performance here soon. That's a digital painting of the School's headmistriss, Penny Maple, above.Follow the jump for digital paintings inspired by Elle Xombeah, Lavender Menace, Lili Lugosi, Kitty Killton and Pepper Fandango herself. And you can click the images for larger versions.
Friday, October 05, 2012
Shocka Con In Photos
The PopCulteer October 5, 2012
Happy Horror Time
The first-ever Shocka Con took place last Saturday on D Street in South Charleston, and it was a rousing success, exceeding all expecations. Organizers said that they'd be happy with 300 to 800 attendees, and instead upwards of 2,500 people showed up at various points during the day-long, mostly free event.
This was the first year for the Horror/Sci Fi Con, and because it was first conceived only a few months ago, plans were scaled back from a standard three-day convention to a one-day event based around South Charleston's Mound, with films shown at The Labelle Theater and seminars at The South Charleston Public Library, just a coouple of blocks down D Street.
The even was free, but donations were accepted so they can get an early start on next year's convention. While next year's Shocka Con is expected to be a more conventional convention, I'm hoping that some of the cool elements that made this year's show such a success are retained. The Monster Parade and free concert were hugely popular.
Monday, October 01, 2012
Farnsworth Rocks Budget Tapes and Records on RFC 170, plus Weirdness and Meet Ginger From The Stock Car Musical
[HTML1]
Radio Free Charleston 170, "Regular Show Shirt," is a valentine to Budget Tapes and Records, the legendary music and lifestyle emporium that is celebrating forty years of serving area music fans from their Kanawha City location. Our host segments originate from Budget, and we even have two songs by Farnsworth, recorded on location at the release party for their new EP at Budget.
RFC 170 also brings viewers a song from the Contemporary Youth Arts Company production of the Dan Kehde/Mark Scarpelli original, "The Legend of Ginger and Billy Joe: The Stock Car Musical," as well as animation and a found film compilation by Frank Panucci.
Radio Free Charleston 170, "Regular Show Shirt," is a valentine to Budget Tapes and Records, the legendary music and lifestyle emporium that is celebrating forty years of serving area music fans from their Kanawha City location. Our host segments originate from Budget, and we even have two songs by Farnsworth, recorded on location at the release party for their new EP at Budget.RFC 170 also brings viewers a song from the Contemporary Youth Arts Company production of the Dan Kehde/Mark Scarpelli original, "The Legend of Ginger and Billy Joe: The Stock Car Musical," as well as animation and a found film compilation by Frank Panucci.
Subscribe to:
Posts (Atom)
















