Monday, April 16, 2012

Funkadelic Zombie Ska Madness On RFC 156

[HTML1]

Radio Free Charleston 156, "Warning Trioxin Shirt," is posted above for your enjoyment. This week we have music from The Renfields and The Tom McGees, plus we have a terrific short docu-drama by Stephen Schmidt. But first, we have some corrections to do.

I'm pleading allergy-induced dementia for this. First, the Tom McGees' song that I call "Be Smart" in the show, and "Be Strong" in the credits, is actually called "Enemy Spy Plane Inbound." I know, it's an easy mistake to make. Compounding the errors, I announce that The Tom McGees are playing the Porkchopp3D Trailer Release Party April 26 at The Empty Glass, when in fact it is our other musical guest, The Renfields, who are going to be playing that show. Aside from the two huge mistakes in the scripting process, I was really happy with the host segments, which were shot outside of Kanawha Players Theater, the location of this weekend's Zombie Prom.

The reason we have The Renfields, or at least three-fifths of them, on the show this week is that their leader, Vincent Renfield, is the Master of Ceremonies for The Kanawha Players Zombie Prom, which takes place at KP, on April 21. It's going to be a fun night of Zombie goodness, with dancing, contests, Zombie Prom photos by Mike Winland Studios, and special guests, RJ Haddy from the SyFy series "Face Off" and Jeremy Ambler from The Walking Dead. It's going to be lots of fun...people are just dying to go!

Sunday, April 15, 2012

Monday Morning Art: Beach Blanket Bloodbath

[caption id="attachment_7889" align="aligncenter" width="500" caption="Cornelius Dapperdü, Molly Tilley, Pepper Fandango, Elle Xombeah, and Penny Maple, at the beach,  "][/caption]

Last night's edition of Dr. Sketchy's Anti-Art School in Charleston presented nice beach scenes with just a little murder thrown in. Click the images to see them larger.  There's more after the jump.

Sunday Evening Video: The Tom McGees

[HTML1]

Charleston's punk/ska princes play us out of the end credits of tomorrow's episode of Radio Free Charleston, but tonight you get a sneak peek, without the credits rolling over the footage. Thus, the band performs their song,, "Be Strong," live at The Blue Parrot.

Saturday, April 21, you can catch The Tom McGees at The Empty Glass for the Zombie Prom after party, hosted by the Heart of Appalachia Roller Derby folks.  Sharing the bill that night will be Foz Rotten with Charlie Ant Eaterr, plus Hellbound Honky Tonk. On April 26, On May 4 it's time for The Tom McGees to raise money for themselves, to finish their debut album, "This Just In." Which you can also support at IndieGogo.

So there.

Friday, April 13, 2012

Support The Local Scene

The PopCulteer
April 13, 2012


Support The Local Scene

You've heard me say it a million times: "Support the local scene." But what exactly does that mean? Folks, I'm not just talking about music. Charleston has an arts community. We have an overabundance of creative people working in music, art, film, theater, and even in areas that get overlooked, like the culinary arts, and athletic exhibitions.

This week your PopCulteer tells you how you can support the local scene right now!

Sasha Colette and Farnsworth

Tonight, Charleston-area favorite, Kentucky's Sasha Colette (seen above) and The Mgnolia's, with Charleston's own Farnsworth in support, play at The Sound Factory, on Kanawha Boulevard, starting at 10 PM. Admission is a mere five bucks.

Monday, April 09, 2012

The Amorous, Godmode Broadway, DualCore and Stark Charleston Embiggen RFC 155

[HTML1]

[caption id="attachment_7849" align="alignright" width="180" caption=""Love Robot" by Rebekie B"][/caption]

Above you see Radio Free Charleston 155, "Love Robot Shirt," featuring music is from The Amorous, Godmode Broadway and Dual Core, plus the return of Stark Charleston. Host segments were shot in the parking lot of the WV Division of Tourism in South Charleston. Our title shirt is a TeeFury design by artist, Rebekie B.

Our first musical guest on this week's show is Clarksburg's The Amorous. An indie-pop band with spiritual leanings, they will be recording their first full-length album this summer. You can catch them next weekend in Wilmington and Bellbrook Ohio, and at the end of the month they're doing a three-night stand at The Horizon's Church in Lost Creek WV. We recorded the band live during Charcon last year, and assembled this video using audio enhanced with a studio recording.

Sunday, April 08, 2012

Monday Morning Art: Beetle Or Spaceship?

For some reason, this post did not go up as scheduled, and I didn't notice until late Monday. This is being post-dated so that it doesn't knock the production notes for RFC 155 off the top spot of the blog.

It's a digital painting. Click to see it bigger. And watch RFC 155, too.

Thursday, April 05, 2012

Captain Action's Triumphant Return

The PopCulteer
April 6, 2012


This week your PopCulteer is going to return to his roots a bit. Back in the late 1990s I wrote a monthly action figure column for Toy Trader Magazine. It was a load of fun, and from what I'm told, it was pretty influential. Ii would present the latest toy industry news, rag on cheesy knockoffs and present detailed reviews of the latest action figures

When Toy Trader was bought up and shut down by Toy Shop (we were eating into their circulation, but their parent company had deeper pockets), I continued to write for Mastercollector.com for a while, but eventually I moved on to other assignments (like PopCult and Radio Free Charleston).

However, I never left the hobby. I still collect toys, in particular 1/6 scale action figures. As long-time readers of PopCult know, one of my favorites is Captain Action. Originally released in the 1960s, Captain Action was a cool crime-fighter with a great gimmick--he could change into other characters such as Superman, Batman, Spider-man, Captain America and others (uniform sets sold separately).

[HTML1]

Back in the first month of PopCult, I wrote about Captain Action, and my role as a cheerleader for the short-lived 1999 revival. More recently, I've written about the good Captain's return to comic books, his stint as an 8-inch-tall MEGO-style action figure, and his pending return as a full-sized 1/6 scale hero, complete with cool uniform sets.

Now I've got my hands on the first releases in this revived line. These are the basic sets that are just now showing up at Toys R Us. More deluxe sets are on sale in comic book stores and hobby shops, and we'll list some mail-order sources for you at the end of this piece. This week PopCult is going to play with toys.

Sunday, April 01, 2012

Monday Morning Art: Roi #1

Today's Art is a digital painting of a royal ceremonial mask or something. It just sort of happened organically while I was messing around on the computer. Click it to see it bigger.

Also, don't miss RFC 154, posted over the weekend. It presents a look at a lost piece of West Virginia film history.

James Bond In West Virginia On RFC 154

[HTML1]

[caption id="attachment_7808" align="alignright" width="200" caption="Steve E. Beckner as "Bond, James Bond""][/caption]

"Adventure Comics Shirt" is a special episode of Radio Free Charleston, dedicated to presenting once-thought-lost scenes from The Lower West Virginia Contemporary Light Opera Stage Players film production of the James Bond film, "Coalfinger." All prints of this film were destroyed after MGM,  EON Productions  and the Ian Fleming estate won a permanent injunction against the tiny, Southern West Virginia theater company Luckily, a few scenes were preserved in filmmaker Johnny Rock's long-supressed documentary on the making of "Coalfinger."

[caption id="attachment_7809" align="aligncenter" width="500" caption="Audiences have been waiting nearly 20 years to see this title sequence."][/caption]

Thursday, March 29, 2012

Loads Of Cool Stuff

The PopCulteer
March 30, 2012


WVSU Alumni All Star Jam

If you watched the latest episode of Radio Free Charleston, then you already know about the 2nd Annual WVSU Alumni All Star Jam. But just in case you haven't heard, this show features just some of the talented musicians and vocalists that have passed through W.Va. State. Honoring all of West Virginia's great jazz and blues artists past, present and future.

The line-up includes: Tim Courts (Bob Thompson Unit), Jonathan Wesley (Inspirati...on), Mike "Nemo" Pleasant, Lady D, Melanie Larch (Radio Free Charleston's Resident Diva), Dugan Carter (Full Flavor), Dick Stockton and Bill Hambleton. Marshall Petty from the Charleston WV Blues Society and Jack Rice from the West Virginia Blues Society will be on hand as well as special guest, Hubert "Rabbit" Jones.

The show starts at 7:30 PM at The Davis Fine Arts Auditorium on the campus of West Virginia State University. Admission is $10.00 and will benefit the College Book Fund. Call 304.766.3188 for more information.

Monday, March 26, 2012

WVSU Alumni All Stars And Jesus On RFC 153

[HTML1]

Episode 153 of Radio Free Charleston, "Dr. Pepper Shirt," is the video you see at the top of this post. This is a special episode, comprised entirely of rehearsal footage from two of this coming weekend's events, The 2nd Annual Alumni All-Star Jam at WVSU, and the CYAC production of "Jesus Christ Superstar."

I always feel sort of honored to be invited to bring the RFC cameras into a rehearsal because it means that the performers trust me to document their work-in-progress, warts and all. It's a gutsy move, and a sign of confidence on the part of the artists involved.

Of course, I have a bit of an "in" with one performer. Radio Free Charleston's Resident Diva, Melanie Larch, appears in this special edition of RFC, as does Lady D, the WVSU Alumni All-Star Band and the cast of "Jesus Christ Superstar."

Our first two songs are from The 2nd Annual WVSU Alumni All-Star Jam Band. These are early run-throughs, just the first or second time that the musicians have tackled these songs together.

[caption id="attachment_7779" align="aligncenter" width="500" caption="The WVSU Alumni All Star Band: Lady D, Dick Stockton, Tim courts, Melanie Larch, Bill Hambleton, Jonathan Wesley and Nemo Pleasant."][/caption]

Sunday, March 25, 2012

Monday Morning Art: Reclined

This week's artistic jump-start is a semi-abstract design derived from a photo of Kitty Killton taken last week at Dr. Sketchy's.  It's basically an exercise in obscuring reality with multiple filters and overlays. Click the image to see it larger.

And check PopCult later this evening for Radio Free Charleston 153, with Melanie Larch, Lady D and the cast of the CYAC production of "Jesus Christ Superstar."

Sunday Evening Video: RFC 002, "RVD Shirt"

[HTML1]

Tonight's video is a flash back to the second episode of Radio Free Charleston, from July 2006. "RVD Shirt" features music by Stephen Beckner and The Sleeping Dons (Sean Richardson, Jay Lukens and Deron Sodaro), animation by Frank Panucci and a sneak peek at the then-unreleased Batman movie. This episode also marks the first appearence of the infamous Dancing Midget Spider-man (seen right). You can read the original production notes here.

RFC 153, "Dr. Pepper Shirt," with rehearsal performances by Melanie Larch, Lady D and The cast of "Jesus Christ Superstar" will be posted here tomorrow evening.

Thursday, March 22, 2012

A Very Busy PopCulteer Slacks Off And Gives You Cool Images

The PopCulteer
March 23, 2012


Words will be back next week.

Your PopCulteer is swamped with the production of next week's episode of Radio Free Charleston. It's our special rehearsal show. We were lucky enough to be invited to record some footage at rehearsals for two of next week's cool events. Recording and editing ate into what would normally be writing time, so we are going to bring you images this week.

At the iright, you see a digital painting of local starlet, and my imaginary daughter, Kitty Killton, based on a photo from last week's First Anniversary of Dr. Sketchy's in Charleston. You will see a whole bunch more of my digital artsiness from last Sunday in a moment, but first we're going to see three photos taken by Richard Wolfe, of the crew putting on the 2nd Annual WVSU Alumni All-Star Jam. This event takes place Friday, March 30, at the Davis Fine Arts Auditorium at WVSU.

You will see some of the talented musicians and vocalists that have passed through W.Va. State. Honoring all of West Virginia's great jazz and blues artists past, present and future. Line-up includes: Tim Courts (Bob Thompson Unit), Jonathan Wesley (Inspirati...on), Mike "Nemo" Pleasant, Lady D, Melanie Larch, Dugan Carter (Full Flavor), Dick Stockton and Bill Hambleton. Marshall Petty from the Charleston WV Blues Society and Jack Rice from the West Virginia Blues Society will be on hand as well as special guest, Hubert "Rabbit" Jones. Admission is $10.00 and will benefit the College Book Fund. Call 304.766.3188 for more information. We're treating you to a couple of songs from this show on next week's Radio Free Charleston.

We're also going to feature a song from the Contemporary Youth Arts Company production of "Jesus Christ Superstar," which opens next Thursday night at The WVSU Capitol Center Theater. Full details on both show will be included in the production notes for RFC 154.

But now, it's picture time!

[caption id="attachment_7746" align="aligncenter" width="500" caption="Photo by Richard Wolfe: Jazz Next Week, Alumni Jam with Jonathan Wesley, Dick Stockton, Lady D, Dugan Carter. Mel Larch, Tim Courts, Mike Pleasant, Bill Hambleton. FINE ARTS ON FRI THE 30TH @ 7:30 $10"][/caption]

Monday, March 19, 2012

Metal, Ska and Soul Converge on RFC 152

[HTML1]

Above you in this blog, you see RFC 153, "Machine of Madness Shirt," with music from Linework, The Tom McGees and the team of Chad Foss and Sean Sydnor. There;s also a couple of weird short films and some animation, and Lee Harrah is on hand to plug an upcoming all-ages show.

Host segments were shot at various points on Charleston's West Side. Our namesake shirt this week is "Machine of Madness," by Heartjack. This design is a mash-up of Lovecraft and Big Daddy Roth, with Cthulu tooling around in a Hot Rod. Heartjack is also known as James Mitchell, and he has a graphic novel out that you can find here.

Sunday, March 18, 2012

Monday Morning Art: Dr. Sketchy's Pinups

Last night Dr. Sketchy's celebrated one year in Charleston with a night of Pinup poses featuring Kitty Killton, Sarkany and newcomer, Afrodesiac. You see a group shot above. Individual poses from each model can be found on the other side of the jump.  These are just quick digital paintings. Check back in this week's PopCulteer for some more involved images from this session. Click the images to see them larger, and don't forget to come back to PopCult tonight for the newest episode of Radio Free Charleston.

Thursday, March 15, 2012

A Loaded Weekend And The ArtWalk Photo Essay

The PopCulteer
March 16, 2012


So many things are going on this weekend that we actually started it last night with ArtWalk, which you will see in photo essay form below. But first, let's look at the stuff to do.

The Pub Crawl

This weekend's big event is St. Patricks East End Pub Crawl. Saturday, March 17 from 6-10 PM it's time for shamrocks and spirits as five
of the most popular East End pubs and restaurants in Charleston host the first ever Pub Crawl.

The pub crawl will run from 6 to 10 PM at five East End venues: Bluegrass Kitchen, Tricky Fish, the Little India Lounge, the Red Carpet Lounge and The Empty Glass. There will be food and drink specials, as well as live entertainment. Participants can earn prizes in the Shamrock Challenge, where they try to find 15 "strategically placed" shamrocks in the five locations and upload images of them onto a Facebook fan page.

Sunday, March 11, 2012

Powerful Music On RFC 151 With Buddy Black, Prank Monkey And Karma To Burn

[HTML1]


We are back into the thick of things with Radio Free Charleston 151, "The Tom McGees Shirt," our first all-new episode of 2012! In this show, you will find music by Buddy Black, Johnny Compton with Prank Monkey and Karma To Burn We also get a preview of Danny Boyd's graphic novel project, "Carbon." Host segments were shot on a beautiful, windless, Sunday morning at Haddad Riverfront park. Our show is named after Charleston's punk/ska band, The Tom McGees, and we have news about an upcoming show by them.

Monday Morning Art: Sketchy's Does Kitty Again

Today's Art is a double shot of Digital paintings based on Kitty Killton, your PopCulteer's imaginary daughter, from last November's edition of Dr. Sketchy's Anti Art Show. Kitty will be back for her second stint as Dr. Sketchy's model, along with the debuting Bellarosa, this coming Sunday, March 18, at Kanawha Players Theater. Details can be found here and here.

Click the images to see them larger, and check PopCult later today for RFC 151, "The Tom McGees Shirt," with music from Buddy Black, Prank Monkey and Karma To Burn.

Sunday Evening Video: Back To Square One

[HTML1]

Tonight's video, in honor of RFC 150, is a remastered version of the very first episode of Radio Free Charleston, from July 2006. Check out all the fun with music from Whistlepunk and comedy from The No Pants Players!

Thursday, March 08, 2012

Be In A Movie, RFC News, IWA East Coast Photos And Controversy

Go West, Be In A Movie

Last weekend I spent a couple of days filming a small role in the indie movie, "Ladybeard." This weekend, you can do the same.

Director David Smith is looking for extras for a couple of scenes. You get to show up, sit in the audience at a talent show and also at a weding, and there might even be free cake involved.

Let me quote from the Facebook event page, "Want to be in a movie? Apartment 2B needs extras for two scenes in our new movie Ladybeard! We need extras of all ages to watch a church talent show and dance at a wedding reception. We're filming at First Congregational UCC, across from the court house in Huntington, starting at noon."

Let's hear from David directly...

[HTML1]

Sunday, March 04, 2012

Looking Back At LiveMix For RFC 150

[HTML1]

It's finally here, episode 150 of Radio Free Charleston. "Black Shirt" is a celebration of LiveMix Studio, our production partner without whom Radio Free Charleston would not exist. LiveMix is gone now, but in this episode, we revisit some of the incredible performances and speak with some of the musicians who helped make our first 150 episodes so special.

RFC Big Shot Brian Young, one of the owners of LiveMix, speaks extensively about recording some of the bands, while we also have comments from performers Raymond Wallace, Dave Roberts, Lee Harrah, Melanie Larch, and in archival footage, Tom Medvic and Dan Jordan of Feast of Stephen.

LiveMix Studio was shut down in late 2010 when it became the property of Sacred Heart Co-Cathedral, who decided they wanted to be more selective in the ways in which they serve the community. The building sits empty now, but the memories remain and they are some killer memories. 

Monday Morning Art: Ain't That A Kick In The Head

Today's art is a digital painting based on a photograph of "The Supernatural" Zach Vincent delivering a kick to the head of Smokey C at last Saturday's IWA East Coast event, "Extreme Dreams."  A full photo essay devoted to this show, along with a complete rundown of matches and photos of the surprise appearance of Shane "The Franchise" Douglas, will be the centerpiece of this week's PopCulteer on Friday.

Also, be sure to check PopCult today for RFC 150, our big milestone show that presents over 40 minutes of classic performances from the much-missed LiveMix Studio. And click the image above to see it larger.

Sunday Evening Video: Very Busy

[HTML1]

Your PopCulteer had a very long day, with no time to pick out a really cool video this evening, so here's film of a  monkey washing a cat.

Thursday, March 01, 2012

Tommy Dreamer Wrestles In Nitro, OSCAR's Botched Memorial And More Photos From DC

The PopCulteer
March 3, 2012


Hardcore Wrestling legend, Tommy Dreamer, will face our old buddy, Man Man Pondo, in Nitro Saturday night for IWA East Coast.  Dreamer made his mark as the "Innovator Of Violence" in ECW, later moving on to WWE and TNA.  He's facing Mad Man Pondo in the main event of a loaded card.

"The Dark Child" Chance Prophet will face Omega Aaron Draven, and Two Tuff Tony will meet "The Bulldozer" Matt Tremont. Check out the video below the show poster. There are loads of other great matches scheduled for the night.

Tickets are fifteen bucks for ringside seats, ten for general admission. A meet-and-greet will take place at 6 PM. That's an extra five dollars for exclusive access to the wrestlers an hour before bell time.

It all happens at King's Outreach Center (formerly Nitro High School), 302 21st St., Nitro. Advance tickets can be pruchased through IWA East Coast.com.

Sunday, February 26, 2012

Monday Morning Art: More Giallo

Today's art is another digital painting from last week's edition of Dr. Sketchy's.  That's KB as the killer from the Italian-thriller-based ssession.  Next month the first anniversary of Dr. Sketchy's sees Kitty Killton return along with the debut of Bellarosa for a night of classic pin-up poses.  That's March 18 at The Kanawha Players Theater.  As always, click to see the image larger.

Sunday Evening Video: Coming Attractions

[HTML1]

What the headline says. Radio Free Charleston 150 is coming soon, and 151 will follow a week later, with the full video that is briefly previewed above. See how lethargic we are after taking two months off!

Friday, February 24, 2012

Phone Follies, Face Off, Fun Weekend Stuff And Vacation Slides

The PopCulteer
February 24, 2012


This week, your PopCulteer brings you a suggestion for a law what there oughta be, Face Off photos,a rundown of several really cool weekend events which all appear to be happening simultaneously, and part one of a photo essay on what I did on my Winter vacation.

A Modest Proposal

This week, the FCC announced that they were tightening the rules on robo-calls.  It seems everyone is getting those damned annoying recorded messages about lowering your interest rates or selling you a security system or some other scam.  These calls are a major nuisance, being made by people who obviously don't care one whit about the Do Not Call List.  In fact, the theory is that the only reason these calls are even being made is to send referral calls to poor saps who have been stupid enough to pay money for "work at home" kits that basically include a Magic Jack and a guarantee of a steady stream of incoming potential sales calls.

Sunday, February 19, 2012

Monday Morning Art: Giallo

Last night, Dr. Sketchy's paid tribute to Giallo, the Italian film genre of horror/crime thriller noted for the artful and copious use of blood in the murder scenes.  Last night's models, Dolly Dagger and KB, demonstrated, and today's art is a digital oil, taken from last night's session. Dr. Sketchy will return on March 18 with their first anniversary show at Kanwha Players Theater.

Thursday, February 16, 2012

Starstruck On The Web, Collaborators On The Outs, Wrestlers In The Ring and Giallo at Dr. Sketchy's

The PopCulteer
February 17, 2012


Your PopCulteer brings you more comics news, including yet another discussion of comic book creator's rights, plus an interactive website launch based on one of our previous Cool Comics, and news of a surprise wrestling event and this month's edition of Dr. Sketchy's.

Starstruck Like You've Never Seen It

Today, a new website devoted to Elaine Lee and Michael Kaluta's graphic novel "Starstruck", goes live. "Starstruck," based on a stage play written by Lee, Susan Norfleet and Dale Place in the early '80's, has a thirty year publishing history, but was most recently presented in a re-mastered format as a thirteen issue mini-series and deluxe hardcover by IDW Publishing. There's also a really cool audio comic adaptation as well.I raved about the comic here (scroll down), and the audiocomic here.

For more on the website, we will quote directly from Elaine Lee, "The purpose of this site is to try and reach new audience outside "the comics ghetto." By this I mean the huge number of people who are interested in science fiction, space opera and web comics, but who have never walked into a comic shop.

Sunday, February 12, 2012

Monday Morning Art: Valen Tine

Tomorrow is Valentine's Day, and if a blogger can't post a nice piece of art that incorporates a portrait of his girlfriend, then there's something really messed-up in this world. So there!

Click to see it larger.

 

UPDATE: As of February 15, that would be my fiancée, Melanie.

Sunday Evening Videos: The Aquabats Are Coming!



[HTML1]

To The Hub, that is. The Hub (formerly Discovery Kids) is the home of loads of cool stuff, from reruns of the 1960's Batman show, to classic and new GI Joe and Transformers cartoons and starting on March 3, The Aquabats bring their super-hero-ninja-ska moves to the network with "The Aquabats Super Show!" Check out these videos and stay tuned to PopCult for more information in the coming weeks.There's way more after the jump!

Thursday, February 09, 2012

Way More On Comic Book Rights, Plus Weekend Events & Uncle Grandpa

The PopCulteer
February 10, 2012


You Gotta Fight For Your Rights To Comics

Revisiting last week's "Watchmen" item in the PopCulteer, I don't want it to seem like I'm completely coming down on the side of DC Comics in the whole creator's rights issue. There are a few facts that can't be denied. First, DC Comics, like most corporate entities, has a pretty dodgy history when it comes to treating creative people in a fair and ethical way. Second, recent changes in copyright law have greatly confused matters for everyone involved. Third, while DC Comics has treated Alan Moore exceptionally well compared to other creators, that's mainly because he's made them a buttload of money over the years. Creators are still running into a brick wall at times with DC.

Sunday, February 05, 2012

Monday Morning Art: In Like A Lion

This week's art is a digital painting of a big ferocious beastie, the king of the jungle, in fact. Why post a painting of a lion? I guess all the political coverage inspried me.  To see the image larger, just click on it, right in the darn face, if you dare.

Sunday Evening Video: Emily Dickinson Returns

[HTML1]

Last night I saw the Contemporary Youth Arts Company production of "The Belle Of Amhearst," a play by William Luce that uses the poets own words to weave a narrative that lets us spend an evening with the much-loved innovator of verse, Emily Dickinson.  This is a one-woman show, and it is an amazing performance by Mandy Harper. This George Washington senior pours herself into the role and becomes Emily Dickinson for over 90 minutes. It's quite a feat of theater, and something that should be witnessed by every patron of the arts in this town. Our video tonight is a brief snippet of the show.

Harper manages to act and embody the words of Dickinson. She does not merely recite them, instead making them come to life in a delightfully vibrant way.  I've seen Mandy in CYAC shows for almost two years now, and it's wonderful to see her shine like this. Kudos to director Dan Kehde for guiding this production to the stage.

You have three more chances to see "The Belle Of Amhearst," February 9-11 at the WVSU Capitol Center Theater, 123 Summers Street, Charleston. Produced by The Contemporary Youth Arts Company. Performances start at 8 PM. Tickets are ten dollars for adults, six dollars for students and seniors.

 

Thursday, February 02, 2012

Who Watches The Cool Weekend Events Before Watchmen?

The PopCulteer
February 3, 2012


We have some cool stuff in The PopCulteer this week, from cool local events to a big comc book controversy. So let's jump right into the thick of things.

The Belle of Amherst

The Contemporary Youth Arts Company is presenting a show that's a bit of a departure for them beginning this weekend. Last night saw the opening of The Belle of Amherst, a one woman show about Emily Dickinson. This 1976 Broadway play written by William Luce is a tour de force performance by George Washington High School senior, and CYAC veteran, Mandy Harper, who plays the poet, along with fourteen other characters.

Sunday, January 29, 2012

Monday Morning Art: Vortex Ritter

We kick this week of PopCult off with an abstract digital painting that has a funny name. It's an exercise in combining organic and mechanical techniques into the creation of something new and artificial. Sort of like the Chicken McNugget, only better tasting and better for you. As always, click the image to see it larger.

Sunday Evening Video: Rubber Soul

Last year, Charleston's own Beatles Tribute Band, Rubber Soul, performed The Beatles (White Album) in its entirety at The Alban Theater in St. Albans.  This year they're back to bring the classic album, "Abbey Road" to the live stage.

Friady and Saturday, February 3 and 4, at 8 PM, Rubber Sould will once again grace the stage of The Alban Theater,  65 Old Main Plaza, St. Albans, with all of Abbey Road, from start to finish!

Tickets are $10, and the show is a benefit for The American Heart Association. Sponsored by Brooks Run Mining Company.

An added treat on Friday night is The Tom McGees, a hot Ska outfit, who will be performing sort of across the street after Abbey Road wraps up. For a mere five bucks, you can help David Scarpelli (his dad, Mark, is the man behind Rubber Soul) celebrate his birthday with a mad Ska meltdown at The VIP Lounge, 54 Olde Main Plaza, St. Albans, WV.

To remind you how much fun Rubber Soul is, tonight we're bringing back episode 117 of Radio Free Charleston, which previewed last year's White Album show. Enjoy, and come out to see the show.

[HTML1]

Friday, January 27, 2012

Back In The Random Saddle

The PopCulteer
January 27, 2012


Brain Stew

Last week your PopCulteer was missing in action for the first time in nearly three years. Circumstances beyond our control, including a computer virus and a real-world illness, conspired to knock yours truly out of commission. We are feeling better this week, and the PC problems are just about resolved, so we're going to tenatively climb back on the blogging pony and bring you a column of random images, news items and odd bits of information..

Popeye Returns

In April IDW Publishing launches a new comic book based on Popeye The Sailor, one of my personal favorites, and not just because of the spinach.

Sunday, January 22, 2012

Monday Morning Art: Back To The Peoples

This week your Pop.Culteer is rebuilding his computer after a particularly nasty virus. Today's art is the first thing pooted out while trying the reinstalled graphics program. It's a digital painting of The Peoples Building on Summers Street. Click to see the image larger, and expect PopCult to be back to normal this week.

Sunday, January 15, 2012

Monday Morning Art: Substitute Art

Your PopCulteer is a bit under the weather this week. That's why there was no Sunday Evening Video last night, and why today's art is NOT from last Friday's Twin Peaks edition of Dr. Sketchy's.  Between a nasty computer virus and a real-world head-exploding sinus infection, I was in no shape to go out anywhere this weekend.

So in place of a Dr. Sketchy's piece, I am bringing you a digitally-assaulted vintage pin-up photo, glommed from somewhere's on the internet. As always, click the image to see it bigger.  The computer problem and swelling, itching brain are probably going to combine to delay Radio Free Charleston's 150th episode until February.  It's going to be a tribute to LiveMix Studio, and will be the first of at least five retrospective shows planned for 2012. I gotta go pill up now.

Thursday, January 12, 2012

How TV Warps Reality

The PopCulteer
January 13, 2012


"But If It's On TV It Must Be Real!"

Reality is being warped. Television is to blame. I'm not talking about the kind of skewed reality you find on FOX News, where the bizarre notion that Republicans can be trusted to govern is pounded into viewer's heads 24 hours a day. I'm talking about the unreal world of Reality TV.

I'm not a big fan of reality television. In fact, you could probably safely accuse me of being rather snobbish about it. I think it's lowest-common-denominator programming that carries with it the bottom-line-enhancing quality of being dirt cheap to produce, mostly by non-union crews.

But it is booming. Reality shows have spread like a fast-growing cancer, mutating several formerly sophisticated cable channels into slack-jawed, drooling shadows of their former selves.

Sunday, January 08, 2012

Monday Morning Art: More Dangerous Curves

This week we once again go back to Friday, December 29, when the Burlesque troupe, Dangerous Curves Ahead, came to town and participated in a special session of Dr. Sketchy's. Above you see Clams Casion. After the jump you can see more digitally-assaulted photos of Darlinda, Just Darlinda, Minnie Tonka and Anita Cookie. The next edition of Dr. Sketchy's is a tribute to Twin Peaks, Friday, January 13.

Click to see 'em bigger, and follow the jump for three more!

PopCult Instant Video: Captain Crash & The Beauty Queen

[HTML1]

Our video this week is a recording made last Friday at Taylor Books. Captain Crash and the Beauty Queen returned to action with a fun, confident set. Jonathan Slack and Laura Summerhill have been appearing on Radio Free Charleston since 2007, and it's always a treat to catch up with them. In this video, shaky at times, you'll hear the duo performing The Beatles' song ,"Across The Universe," and their original tune, "Getaway Lane." Meanwhile, your loyal PopCult blogger is still hard at work assembling RFC 150.

Also, yesterday was Jonathan's birthday, so happy birthday, and thanks for the music!

Thursday, January 05, 2012

15 Random Bits Of Coolness To Ring In The New Year

The PopCulteer
January 6, 2012


We start a new year of The PopCulteer on an upbeat note as we look at 15 cool things that we're looking forward to early in 2012.

These are some of the cool items to spice up our lives as we face a year of dirty politics, extreme weather, fracking-induced Earthquakes, people insulting our state and, if the Mayans are right, the end of the world. So...at least there's this...

Absolutely Fabulous Returns

Absolutely Fabulous, which has to be ranked among the elite British comedy shows, is returning with two new episodes, the first in six years, this month. BBC America will debut a new episode, "Identity," Sunday night at 10 PM, with a second episode, "Job," to follow in a week. Of note: Jennifer Saunders, the show's writer/creator and co-star, has not missed a beat. Despite the six years since the last series, the show is as sharp and timely as ever. A new title sequence returns to the original recording of "This Wheel's On Fire," sung by Julie Driscoll and Saunders' husband (and RFC supporter) Ade Edmondson, of "The Young Ones" fame. And the shows already appeared on The BBC on Christmas and New Year's Day, so the torrent-minded among you can probably already find them now.

Sunday, January 01, 2012

Monday Morning Art: Dangerous Curves Ahead

[caption id="attachment_7289" align="aligncenter" width="500" caption="Minnie Tonka"][/caption]

Last Friday Burlesque came to Charleston at Kanawha Players Theater as Dangerous Curves Ahead, a troupe from Brooklyn, made their way to the Mountain State. Before the show, a special session of Dr. Sketchy's took place, and us artisitc types where given the chance to photograph and draw Anita Cookie, Clams Casino, Darlinda Just Darlinda,  and Minnie Tonka.

[caption id="attachment_7290" align="aligncenter" width="500" caption="Anita Cookie and Clams Casino"][/caption]

Today we're bringing you digital paintings of the ladiesm as always, click the images to see them larger.

[caption id="attachment_7291" align="aligncenter" width="500" caption="Darlinda, Just Darlinda"][/caption]

PopCult Instant Video: Ryan Sings Bowie

[HTML1]

[caption id="attachment_7282" align="alignright" width="225" caption="Ryan Hardiman and Maddie Gourevich"][/caption]

Tonight we bring you a special treat. This is a very raw video of Ryan Hardiman's God Night performance of "Moonage Daydream: The Bowie Songbook."  Ryan, with some help from guest vocalist Maddie Gourevich, pianist Mark Scarpelli and a string quartet featuring Molly Lynn Page and Kristi Holstein (violin), Alasha Al-Qudwah (viola) and Shawn Simms (cello), performed some of the greatest hits of The Thin White Duke, David Bowie.

This was the 7 and 9 PM Goodnight 2011 show at Trinity Lutheran, presented by Charleston Community Music Association. It was a wonderful night of more challenging music than we usually hear during Goodnight, and it was very well received.